CCProxy Help

CCProxy主要功能和特點

  • 設置簡單，功能強大，完全支援 Win98/WinMe/WinNT/Win2000/WinXP/Win2003。
  • 支援共用Modem、ISDN、ADSL、DDN、專線、藍牙、二級代理等訪問Internet。
  • 支援HTTP、FTP、Gopher、SOCKS4/5、Telnet、Secure(HTTPS)、News(NNTP)、RTSP、MMS等代理協定。
  • 支援瀏覽器通過HTTP/Secure/FTP(Web)/Gopher代理上網。
  • 支援用戶端使用Outlook、Outlook Express、Foxmail等通用郵件用戶端軟體收發郵件。
  • 支援OICQ、ICQ、Yahoo Messenger、MSN、iMRC、聯眾遊戲、股票軟體通過HTTPS、SOCKS5代理上網。
  • 支援CuteFTP、CuteFTP Pro、WS-FTP、FXP-FTP等FTP軟體通過代理上網。
  • 支援RealPlayer通過RTSP代理接收視頻，支援MediaPlayer通過MMS代理接收視頻。
  • 支援NetTerm通過Telnet代理上網。
  • 支援Outlook通過News代理連接新聞伺服器。
  • 支援遠端撥號、自動撥號、自動斷線、自動關機功能。
  • 支援二級代理，可以使代理伺服器通過其他代理伺服器上網。
  • 雙擊介面上的綠色網格可以即時觀測代理用戶連接資訊。
  • 簡單實用的帳號管理功能，可以針對不同用戶定義不同的上網限制。
  • 帳號管理支援IP段設置方式和自動掃瞄帳號功能，建立帳號更輕鬆。
  • 支援多種方式的帳號認證方式和混和應用：IP位址、MAC位址、用戶名密碼、域帳號管理。
  • 支援HTTP和SOCKS5用戶驗證。
  • 內置功能變數名稱解析功能DNS。
  • 時間管理功能：可以自由控制不同用戶的上網時間。
  • 網站過濾功能：可以遮罩特定網站和內容，也可以限定用戶只能上指定的網站。
  • 緩存功能：可以自由設定緩存大小，更新時間，提高訪問速度。
  • 帶寬控制：可以靈活的控制每個用戶端的上網速度。
  • 支援WinNT/Win2K/WinXP/Win2003下以NT服務運行方式。
  • 其他高級功能：載入代理廣告條、啟動時撥號、埠映射、流量計費等，具體用法參加主頁和論壇。

購買CCProxy


安裝說明


代理伺服器硬體和軟體基本要求

1) 伺服器的配置跟用戶數有關。
如果用戶數在20人以內，一般的PC電腦就可以作為代理伺服器了。推薦PII晶片，記憶體128M，硬碟10G。如果用戶數在20人以上100人以下，需要選用專業的伺服器作為代理伺服器，伺服器一定要專用，即專門作為代理伺服器來用。推薦PIII晶片，記憶體256M，硬碟20G。如果用戶數在100人以上，需要選擇高配置的伺服器作為代理伺服器，伺服器一定要專用，即專門作為代理伺服器來用。推薦雙CPU，記憶體1G，硬碟40G。
2) 網卡配置。
盡量選用性能比較穩定的網卡作為伺服器網卡，100M網卡。推薦品牌：原裝D-Link，3COM。由於是作為伺服器網卡，盡量選用高性能中高價位元的網卡。
3) 作業系統。
如果用戶端用戶數在10人以上，我們推薦您安裝Win2000 Advanced Server，並打好最新補丁。Win98只適合10用戶網路環境，Win NT需要打太多的補丁，Win2000 Professional只適合個人和家庭電腦，所以最好選用Win2000 Advanced Server。
4) 殺毒軟體及防火牆軟體。
我們推薦您用Norton殺毒軟體及Norton防火牆軟體來保護您的伺服器。為了方便調試代理伺服器，請在代理伺服器安裝調試成功後，再安裝和使用殺毒軟體和防火牆軟體。


局域網網路環境配置要求

確認局域網連接通暢，能夠相互ping成功。
伺服器的IP設置有幾個需要注意的地方：
1) 檢查伺服器的網路屬性，確保裡面沒有多餘的無用的TCP/IP協定，如果伺服器是Win98作業系統，作業系統安裝過程中會自動添加一些無存在的撥號適配器及相應的TCP/IP協定，需要刪除這些多餘的網卡適配器和相應的TCP/IP協定。否則很容易引起網卡衝突。
2) 如果伺服器安裝了兩塊網卡或者多塊，在網卡IP設置上需要注意，不要將網卡的IP設置在一個網段內，這樣會造成路由混亂。比如一塊網卡是192.168.0.1，另一塊網卡就不要設置成192.168.0.2，可以設置為192.168.1.1。
3) 伺服器的網卡一般不要設置閘道，尤其是連接局域網的網卡，不要設置閘道，否則很容易造成路由衝突。

如果沒有配置好局域網，建議按照下面的方法配置局域網。分配好局域網機器的IP。一般是192.168.0.1、192.168.0.2、192.168.0.3、…192.168.0.254，其中伺服器是192.168.0.1，其他IP位址為用戶端的IP位址。子網路遮罩為255.255.255.0，DNS為192.168.0.1。如果用戶端作業系統是Win98，請設置閘道指向192.168.0.1，DNS主機名填本地機器名。


互聯網接入方式的要求

目前已知的互聯網接入方式中，代理伺服器CCProxy大部分都支援。ADSL撥號用戶(非網卡直連用戶)需要注意的是，由於有些電信自帶的ADSL撥號驅動程式很陳舊，請到我們網站的下載頁面下載新的ADSL撥號驅動程式，以便更穩定的與互聯網保持連接。


缺省代理埠列表

HTTP: 808 - 用於瀏覽器上網
FTP (Web): 808 －用於瀏覽器連接FTP站點
FTP: 2121－用於FTP用戶端軟體連接FTP站點(如CuteFTP)
Gopher: 808－用於瀏覽器連接Gopher站點
Secure/SSL/HTTPS: 808 －用於瀏覽器連接安全站點
RTSP: 808－用於Real Player
SOCKS: 1080－用於部分網路用戶端端軟體(如QQ，聯眾)
MMS: 1080－用於Media Player
News (NNTP): 119－用於Outlook連接新聞伺服器
SMTP: 25－用於郵件用戶端軟體發送郵件(如Outlook，Foxmail)
POP3: 110－用於郵件用戶端軟體接收郵件(如Outlook，Foxmail)
Telnet: 23－用於某些Telnet用戶端軟體，如(CTerm)


安裝中常見的啟動失敗問題


DNS啟動失敗

有兩種可能：
1) 伺服器上安裝了其他代理伺服器軟體。這時需要停用其他代理伺服器。
2) 伺服器缺省安裝了Windows自帶的DNS伺服器。這種情況一般多發生在Win2000上。
因為Win2000已經自動安裝了DNS伺服器，無需使用CCProxy的DNS服務，可以取消CCProxy的DNS代理：「設置「 -> 取消"DNS"選項。


郵件代理啟動失敗

這是因為你的伺服器上安裝了其他跟郵件服務有關的程式，造成衝突。有很多原因造成這種現象：
1) 如果你安裝了可以防止Email病毒的殺毒軟體，可能會造成110(POP3)埠衝突，這時你需要修改殺毒軟體的埠(並不是所有的殺毒軟體可以修改埠，瑞星殺毒支援修改埠)。如果不能修改， 就只好停用這項殺毒功能。雖然CCProxy提供了修改POP3埠的功能，但是我們不建議你這樣做，因為會導致大量用戶端程式跟著修改埠。優秀的殺毒軟體Norton不會有這種現象。
2) 如果你安裝了其他代理伺服器軟體，可能會造成110(POP3)，25(SMTP)埠衝突。因為有些代理伺服器可能也具備郵件代理功能。這種情況下，你需要停止這些代理伺服器中的郵件代理功能。
3) 如果你安裝了防火牆程式，也可能會造成埠衝突。需要開放25(SMTP)、110(POP3)、53(DNS)、80(HTTP)、8011(Admin)、5353(MX)埠。
4) 如果你安裝了郵件伺服器程式，也會造成埠衝突。原因是很明顯的，都用了相同的埠。你必須停止這些郵件伺服器才能使CCProxy運行正常。
5) 如果你能確認其他軟體也能完成郵件代理功能(如CMailServer)，那麼你可以不必再用CCProxy的郵件代理了，從「設置」裡取消「郵件代理」。

一個很簡單的測試本機是否安裝了其他跟郵件有關的軟體的方法：在命令行方式下，輸入命令 telnet 127.0.0.1 110 或者 telnet 127.0.0.1 25，你就可以看到相應的提示資訊判斷出跟哪個軟體有關。


新聞代理服務啟動失敗

有兩種可能：
1) 伺服器上安裝了其他代理伺服器軟體。這時需要停用其他代理伺服器。
2) 伺服器上安裝了微軟的NNTP Service，這是需要停用NNTP服務。
從控制面板->添加/刪除程式->添加/刪除windows元件->Internet資訊服務(IIS)->NNTP Service。 取消NNTP服務。


SOCKS或者HTTP等代理啟動失敗

出現這種問題，主要是因為您的機器已經安裝了其他代理伺服器軟體，造成衝突。
解決辦法是停用這些軟體或者修改CCProxy的代理埠(在CCProxy設置對話方塊裡可以修改)。


用戶端設置說明

用戶端是指需要通過代理伺服器上網的機器。用戶端不需要安裝CCProxy。
常見軟體的設置請看主頁上的圖例 。


用戶端設置前的準備工作

1) 確認用戶端與伺服器是連通的，能夠互相訪問。
2) 確定代理伺服器位址。代理伺服器位址就是安裝代理伺服器的機器的網路位址。
這個位址，是指伺服器在局域網中的本地IP位址。本地IP地址可以從CCProxy的設置對話方塊中得到。
設置對話方塊中的本地IP位址一般情況下可以用"自動檢測"得到。如果伺服器安裝了雙網卡，則需要手工選取：取消"自動檢測"，從列表中選取。
如果不能確認伺服器的IP位址，也可以用伺服器的機器名作為代理伺服器位址。


設置IE瀏覽器代理上網

IE瀏覽器->功能表「工具」->「Internet選項」->「連接」->「局域網設置」->選中「使用代理伺服器」->「高級」->「代理伺服器設置」。
取消"對所有協定均使用相同的代理伺服器"；
在「HTTP」中填上代理伺服器位址，埠為808；
在"Secure」中填上代理伺服器位址，埠為808；
在「FTP」中填上代理伺服器位址，埠為808；
在「Gopher」中填上代理伺服器位址，埠為808；
在「Socks」中填上代理伺服器位址，埠為1080。
請看主頁上的圖例


設置Outlook的郵件代理

請看主頁上的圖例


設置Foxmail郵件代理

請看主頁上的圖例


設置Outlook新聞代理

選擇你已經配置好的新聞伺服器，右鍵功能表->屬性->伺服器，
假設你原來的伺服器名為msnews.microsoft.com，現在將伺服器名改為代理伺服器位址，
選擇「此伺服器要求登錄」，在帳號裡面填上 #msnews.microsoft.com，密碼空缺，
在「記住密碼」前打勾.
需要注意的是，如果您上的不是免費的新聞伺服器，也就是要求您提供帳號和密碼的，
那麼您的帳號名應該修改為：舊的帳號名#原新聞伺服器位址，密碼還是原來的密碼。


設置CuteFTP代理

功能表 Edit -> Settings -> Connection -> Firewall:
Host 後面填代理伺服器位址，埠2121， Type選擇「USER user@site」，在「Enabel firewall access」前打勾。
功能表 Edit -> Settings -> Connection -> Socks -> Use direct connection.


設置CuteFTP Pro代理

功能表「Edit」->「Global Settings」->「Connection」->「SOCKS4 & 5」:
選擇「Use the highlighted Socks server when connecting.」;
選擇「Add」按鈕，刪除Host裡的「<New>」，填上代理伺服器位址，Port填1080。
不要選「Use Authentication」，選擇「Socks5」。


設置ICQ代理

ICQ-> Preferences -> Connections:
"Server" : 選擇"Using Firewall", "Proxy" 選擇"Socks 5"
"Firewall" : 選擇"Socks 5", 在"Host"裡填寫代理伺服器位址，"Port" 填1080,
選擇"use proxy to resolve hostnames"
詳細設置圖請看http://www.youngzsoft.com/tools/icq.htm (假設代理伺服器位址為192.168.0.1)


設置MSN Messenger代理

功能表"工具"->"選項"->"連接":
選擇"我使用代理伺服器"，類型選擇SOCKS 5，伺服器填本地代理伺服器的IP位址，埠1080，其他不填。


設置OICQ代理

在OICQ的系統功能表裡選擇「系統參數」->OICQ參數設置->網路設置, 將上網類型設置為「局域網接入Internet」， 選擇「使用PROXY SOCKET5防火牆」，防火牆地址填上"代理伺服器位址"，埠填上1080。 完成設置後按「測試」按鈕，如果測試正常，表明代理設置成功。
請看主頁上的圖例 。


設置網路螞蟻代理

功能表「Option」->「Preferences」，彈出設置對話方塊，選擇「Proxy」一頁，在列表框裡選擇「Direct connection」，取消「Default for HTTP」和「Default for FTP」選擇，點擊「Add」，在「Name」填上CCProxy，「Addr」填上代理伺服器位址，「Port」填上1080，「Type」選擇Socks5，確定，選擇剛剛添加的「CCProxy」，選擇「Default for Http」、「Default for FTP」和「User default proxy for all jobs」，確定。


設置網際快車FlashGet代理

「工具」->「選項」->「代理伺服器」->「添加」，在名稱裡寫上CCProxy，類型選Socks5->「確定」->在「CCProxy」一行的「Http缺省」和「Ftp缺省」兩列打勾，在「所有的任務均使用缺省的代理伺服器」前打勾。


設置聯眾遊戲代理

運行聯眾遊戲，彈出「選擇連接站點」對話方塊->「設置代理伺服器」: 在「通過代理伺服器(Proxy)連接Internet」前打勾，在「代理伺服器位址」裡填上代理伺服器位址，埠為1080，選擇「使用Socks5協定」，其他為空。


設置客戶機聯網遊戲CS, 石器時代, 三國等代理

這類軟體本身沒有設置代理的功能，就只能求助於NEC的e-Border，需要在用戶端安裝e-Border。獵手與螞蟻收藏館(該網址可以在google搜索螞蟻收藏館)上有完整的NEC e-Border Client 2.11 的解決方法和程式下載。需要注意的是用戶端的網路屬性 -> TCP/IP屬性裡一定要設置DNS，位址填代理伺服器位址。伺服器上的CCProxy設置裡要選擇DNS服務。e-Border簡單設置方法:在用戶端安裝e-Border Client, 打開e-Border設置介面，在General一頁，有三個圖示，有一個"Setup Wizard". 點擊"Setup Wizard" -> "e-Border Client Setup Wizard" -> 選擇 "I want to set up the client" -> 下一步 -> 選擇 "I have one server" -> 下一步 -> 在 Name 裡填上代理伺服器位址，在Port裡填上 1080 -> 下一步 ->選擇 "Does not require authenication" -> 下一步 -> 選擇"Proxy All" -> 完成。注意：用戶端要設置DNS指向代理伺服器。 具體設置請看主頁上的圖例。


設置語音聊天代理

大部分的網站提供的語音聊天都沒有設置代理的功能，需要在用戶端安裝SocksCap32，將語音聊天軟體或者其載體(IE)加入到SocksCap32裡。
詳細的設置方法請看 http://www.youngzsoft.com/cn/sockscap


設置NetMeeting代理

NetMeeting沒有設置代理的功能，需要在用戶端安裝SocksCap32，將NetMeeting加入到SocksCap32裡。用戶端要設置DNS指向代理伺服器IP位址，如果是Win98，需要設置DNS主機名為本機機器名。
詳細的使用方法請看 http://www.youngzsoft.com/cn/sockscap


設置RealPlayer代理

請看主頁上的圖例 。


設置MediaPlayer代理

請看主頁上的圖例 。
完全支援MediaPlayer 7.01 以上版本的MMS代理和HTTP代理。
MediaPlayer 6.4以上版本只支援HTTP代理。


設置NetTerm上BBS站點

功能表「File」->「Phone Directory」。
在列表中選擇一項你想連接的BBS。比如bbs.execpc.com。
這時下面的資訊顯示為：Host Name為bbs.execpc.com，Host/IP為空，Telnet Port為23。
在Host/IP裡填寫代理伺服器位址，就可以了。
單擊「Connect」按鈕，這時藍色顯示幕上會出現: CCProxy Telnet>CCProxy ...等提示資訊，
輸入 open bbs.execpc.com，敲「Enter」鍵，就可以登陸bbs.execpc.com了。
如果不想每次都輸入open bbs.execpc.com，你需要在按照這樣的步驟來做：
1. 用Notepad編輯一個文字檔案。
如果登陸bbs.execpc.com，文本的內容為：
output "open bbs.execpc.com ^M"
如果登錄bbs.tsinghua.edu.cn，文本的內容為：
output "bbs.tsinghua.edu.cn ^M"
2. 將這個文件保存到NetTerm的安裝目錄。
3. 打開「Phone Directory」對話方塊裡選擇對應的登陸伺服器，選擇「Select Logon Script」，
「Select」剛才保存的文件， 點擊「OK」。


設置聊天室代理(基於Java)

因為這類聊天室是用java寫的(如網易聊天室 chat.163.com)，需要設置java虛擬機的socks代理，可以通過
http://www.youngzsoft.com/tools/setjavaproxy.html 來設置java虛擬機的socks代理。 要選擇代理伺服器設置裡的"DNS"，用戶端的DNS要指向伺服器IP位址。


設置Norton Antivirus在線更新病毒庫代理

首先在IE裡設置好http代理，打開Norton Antivirus的LiveUpdate，彈出「Live Update」對話方塊，單擊對話方塊上的"Configure..."按鈕，彈出「Liveupdate Configuration」對話方塊，在「ISP」選項卡裡選擇第一項"the Internet Options ..."，在「Proxy」選項卡裡選擇第三項"I want to use my Internet Explorer ..." 。


設置金山毒霸在線升級代理

功能表「工具」 -> 「升級設置」 -> 選擇「使用socket5代理伺服器」 -> 「設置...」-> 「伺服器位址」填代理伺服器位址 ->「埠」填1080


其他軟體的代理設置

1) 參考主頁上最新公佈的用戶端軟體設置方法。
2) 如果這些軟體本身有代理設置選項(一般在網路設置或者系統設置裡)，就可以參照相應協定和埠進行設置。
3) 如果這些軟體本身沒有代理設置，可以在用戶端安裝NEC公司SocksCap32，將這些軟體加入到SocksCap32裡。
SocksCap的具體設置方法和下載地址請看http://www.youngzsoft.com/cn/sockscap


帳號管理

詳細內容請看主頁上的帳號管理。


帳號管理基本概念

代理伺服器CCProxy的帳號管理分為三個部分。分別是允許範圍，驗證方式和帳號設置。

允許範圍有三種選擇: 允許所有，允許部分和不允許部分。
允許所有是缺省狀態，表示允許所有用戶端上網，此方法適用於不需對用戶端進行上網管理的應用。
允許部分表示只有加入用戶列表的用戶可以上網，並可以實現對用戶進行各種管理。
不允許部分表示只有加入用戶列表的用戶不允許，其他都允許。

驗證類型有六種選擇，此選項用來設置缺省帳號管理方式，編輯單個用戶還可以對單個用戶採用特別的帳號管理方式。
1) "IP地址"是指用戶的身份通過IP地址來驗證;
2) "MAC地址"是指用戶的身份通過MAC位址(網卡的物理位址)來驗證;
3) "用戶/密碼"是指用戶的身份通過用戶名和密碼來驗證;
4) "用戶/密碼+IP地址"是指用戶的身份通過用戶名、密碼和IP地址三者同時來驗證;
5) "用戶/密碼+MAC地址"是指用戶的身份通過用戶名、密碼和MAC地址三者同時來驗證;
6) "IP+MAC"是指用戶的身份通過IP地址和MAC地址同時驗證。

帳號設置:
"新建": 可以新建一個帳號。
"編輯": 可以修改一個帳號。
"刪除": 可以刪除選中的帳號。
"全選": 選中所有的帳號。
"自動掃瞄": 這個功能是方便管理員初始化帳號資訊的，當第一次設置帳號的時候，管理員可以打開所有的用戶端機器，輸入起始IP位址和結束IP位址，然後單擊"開始"，可以自動獲取局域網裡所有用戶端機器的IP位址、MAC位址和機器名。


新建帳號說明

"帳號" -> "新建"
"用戶名/組名": 用來標識不同的帳號。
"密碼":用來設定用戶端上網需要的密碼。
"IP地址/IP段": 可以是單個IP地址，也可以是IP段。比如 192.168.0.1 和 192.168.0.1-192.168.0.10 都是可以的。當設置成IP段時， 表明這個IP段的用戶都共用這個帳號的許可權。
"MAC地址": 是指用戶端網卡的物理位址。
"最大連接數": 是指用戶端允許的最大同時活動的連接數。-1表示不限制用戶端連接數。
"帶寬(位元組/秒)": 是指用戶端允許的最大帶寬，可以用來限制用戶端上網速度。-1表示不限制帶寬。
"服務": 可以指定該帳號的允許服務專案。
"網站過濾": 可以選擇在"網站過濾"中已經定義好的網站過濾。
"時間安排": 可以選擇在"時間安排"中已經定義好的時間安排。


用戶名/密碼驗證方式的說明及注意事項

這種管理方式主要對瀏覽器上網和SOCKS5代理上網進行用戶身份驗證。
如果選擇了包含"用戶/密碼"的驗證類型，用戶端通過瀏覽器上網時，瀏覽器會彈出要求輸入用戶名和密碼的對話方塊，用戶名和密碼只是在啟動瀏覽器第一次訪問網站時需要輸入用戶名和密碼，從已經打開的瀏覽器裡訪問新的網站和打開新的視窗不需要再次輸入用戶名和密碼，但是啟動新的瀏覽器訪問網站會要求再次輸入用戶名和密碼。通過SOCKS5協定上網的軟體也需要在代理設置裡填寫用戶名和密碼。如QQ。
注意: 如果要對用戶端開放郵件代理，FTP代理，SOCKS4代理等服務，必須結合IP位址、MAC位址等驗證方式，或者建立一條新的帳號，採用IP地址或者IP段管理方式來開放其他服務。


如何控制用戶端上網速度

控制用戶端上網速度需要帳號屬性裡的兩個參數來限制："最大連接數"和"帶寬"
"最大連接數"是指伺服器同時回應的用戶端的最多的連接數，該用戶端多餘的連接將被代理伺服器自動掛起，直到該用戶端釋放出已經回應的連接。
"帶寬(位元組/秒)"是指用戶端最大的每秒鐘的位元組流量。

通常情況下，我們可以設置用戶端的最大連接數是10個，帶寬為10240(即為10K)。如果要嚴格控制用戶端使用網路螞蟻的情況，可以適當減少帶寬或者最大連接數。


網站過濾的說明

網站過濾可以有效的控制用戶端訪問的網址。
操作："帳號" -> "網站過濾"
可以定義不同的網站過濾規則。"網站過濾名": 輸入不同的網站過濾名，用來標識不同的網站過濾規則。
網站過濾分為"站點過濾"、"禁止連接"、"內容過濾"。
注意: 這裡只是定義網站過濾規則，如果要應用該網站過濾規則，需要編輯相應的帳號，選擇和應用該規則。

站點過濾
在編輯框裡，可以輸入多個過濾站點，以分號分隔。站點過濾支援通配符(*,?)。
如：*.yahoo.com;???.hotmail.com;www.*.org
如果站點包含多級功能變數名稱，比如sina，包含了www.sina.com.cn;www.sina.com，應該用*.sina.*.*;*.sina.*來過濾，而不是只用*.sina.*來過濾。
"允許站點"，"禁止站點": 決定過濾的站點是允許訪問還是禁止訪問。
注意: "站點過濾"中的"允許站點"僅適用於結構簡單的站點(如本公司站點)，不適應如163、sina等站點，因為此類站點結構比較複雜，頁面中有些圖片等資訊來自於其他站點，會造成頁面顯示不全等問題。

禁止連接
在編輯框裡，可以輸入多個禁止連接內容，用分號分隔。下面是一些參考的例子：
如果要限制用戶端下載文件可以用.exe;.zip;.rar;來過濾。
如果要防止用戶端用webmail收發郵件，可以用mail;來過濾。
如果要防止用戶端上網頁BBS聊天，可以用chat;bbs;來過濾。

內容過濾
可以過濾含有特定文字的網頁。只要該網頁含有特定字元，就可禁止顯示該網頁。
"內容過濾": 實現此網站過濾的"內容過濾"，可以過濾多個內容，內容之間以分號分隔。如：sex;chat;travel
注意: 因為是進行全文內容過濾，此功能會對伺服器資源造成一定壓力。


如何對帳號實行網站過濾及注意事項

首先，通過"帳號"->"網站過濾"來定義不同的"網站過濾"規則。
然後選擇需要進行"網站過濾"的用戶端的帳號，編輯該帳號，在"網站過濾"裡選擇先前定義好的"網站過濾"規則。
注意: "站點過濾"中的"允許站點"僅適用於結構簡單的站點，不大適用於諸如163、sina等站點，因為此類站點結構比較複雜，頁面中有些圖片等資訊來自於其他站點，會造成頁面顯示不全等問題。


時間安排的說明

控制用戶端上網時間由"時間安排"功能來實現。
"時間安排"用來設置用戶端的上網時段。
"帳號" -> "時間安排"：定義不同的時間安排規則。

"時間安排名": 可以輸入不同的時間安排名，來標識不同的時間安排。此標識名將用於每個用戶的帳號設置裡。
"星期天"至"星期六": 用來設置不同工作日的上網時間安排。
可以直接在編輯框裡設置時間，時間段用"起始時間-終止時間"來表示，不同時間段之間用"+"連接。如07:30-11:30+13:30-17:30，表示上午7:30至11：30分和下午1:30分至5:30分的時段內可以上網。
也可以點擊編輯框旁邊的按鈕，彈出"時間表"對話方塊，可以用來設定相應工作日的時間安排。
"時間表"裡有24個時間選擇，表示不同的時間段。如選擇"01:00"，表示00:00至01:00可以上網。
"應用於"表示該時段的時間控制只對所選的服務有效。


如何對帳號進行時間控制

首先，通過"帳號"->"時間安排"來定義不同的"時間安排"規則。
然後選擇需要進行時間控制的用戶端的帳號，編輯該帳號，在"時間安排"裡選擇先前定義好的"時間安排"規則。


如何使用自動掃瞄獲取所有用戶端的機器名、IP位址和MAC位址

管理員先打開所有的用戶端機器，"帳號"->"自動掃瞄"，輸入起始IP地址和結束IP地址，然後單擊"開始"，可以自動獲取局域網裡所有用戶端機器的IP位址、MAC位址和機器名。


為什麼無法獲取用戶端的MAC位址

這種情況一般有以下三種原因:
1) 伺服器或者用戶端遮罩了137埠，CCProxy掃瞄用戶端MAC位址需要用到137埠發送UDP資料包;
2) 局域網網路環境不好或者網路繁忙，網路堵塞也會導致部分MAC地址掃瞄不到;
3) 用戶端沒有安裝NetBIOS協定.
解決辦法：
1) 關閉和伺服器和用戶端的防火牆或殺毒軟體，開放137埠;
2) 修改cproxy.ini中TimeoutMAC=的值, 默認是200, 可改為1000, 表示掃瞄時間為1秒;
3) 用戶端安裝NetBIOS協定。


如何向用戶端發送資訊

用戶端如果是Win98，要求已經運行了windows目錄下的WINPOPUP.EXE。如果是Win2000/NT，則系統已經自帶了消息接收功能。
在帳號管理裡點擊右鍵，在上面的編輯框裡輸入對方機器名，下面的編輯框裡輸入要發送的文字，點擊確定就可以發送資訊到用戶端了。如果上面的對話方塊裡輸入的是"*"號，可以發送到局域網裡的任何一台機器。


如何實現對域和域帳號的支援

CCProxy支援用本地或者局域網域伺服器的帳號作為用戶名/密碼驗證帳號。
ccproxy.ini中參數NTDomain=. 默認為CCProxy軟體所在伺服器的域，可改為局域網中其他功能變數名稱稱;
ccproxy.ini中參數NTUserAuth=0改為1，即可實現對域帳號的支援。
注意:
1) 啟用此服務時，不可啟用域帳號中的guest帳號,否則會造成所有用戶都可以上網;
2) 啟用此服務時，僅適用於WWW和SOCKS5服務身份驗證;
3) 如果要對某帳號進行"網站過濾"、"時間安排"等服務，須在帳號中建一個與之相同用戶名和密碼的帳號，然後對新建的帳號進行管理。


如何讓用戶在不同的時間段內上不同的網站

可以為該用戶建立不同的帳號，並為每個帳號設置不同的"時間安排"和"網站過濾"規則,即可實現對該用戶進行分時管理。
比如：允許甲用戶在8:00-10:00時間段內，只能訪問新浪網站，在11:00-12:00時間段內,只能訪問雅虎網站，那麼可以進行如下操作:
1) 建二條"網站過濾"規則，分別為"只允許訪問新浪網站"和"只允許訪問雅虎網站";
2) 建二條分別為8:00-10:00和11:00-12:00的"時間安排"規則，並"應用於"WWW服務;
3) 為該用戶在帳號中新建兩個不同帳號，並為其設置好相應的"時間安排"和"網站過濾"就可以實現分時管理。


如何讓用戶在上班時間只允許收發郵件,下班時間既可以收發郵件又可以瀏覽網頁等其他功能

假設用戶NEC在7:00-11:30和13:30-17:30之間只允許收發郵件，其他時間既可以收發郵件又可以瀏覽網頁等其他功能。
我們分析這個需求不難發現這樣的規律：用戶端收發郵件是不受時間限制的，也就是說我們只需要對郵件代理以外的其他服務進行時間管理。那麼可以進行如下操作:
1) "帳號"—"時間安排"，建一條規則time1，然後分別點擊"星期日"至"星期六"後面的"…"按扭，設置好相應的時間段，"應用於"裡不選擇"郵件";
2) 編輯"NEC"帳號，在"時間安排"前面打勾，並選擇"time1"規則即可。

當然我們也可以這樣做，為該用戶建立兩個帳號。
1) 一個帳號只開放郵件代理服務，設置時間規則為任何時間都運行上網（實際上可以不選擇時間規則）;
2) 另一個帳號只開放除郵件服務以外的伺服器，設置時間規則：00:00-7:30，11:30-13:30和17:30-24:00可以上網。


用戶通過web方式發送郵件時如何禁止發送附件

在"內容過濾"裡加入";; filename="。(注意: 有兩個分號，在在第二個分號後面有一空格，如果有其餘過濾的內容如chat等，此過濾內容必須放在第一位)


如何限制用戶使用QQ

ccproxy.ini裡將Socks5UDP=1改為SOCKS5UDP=0。所有用戶端都不能用QQ了。
如果只想遮罩某個用戶端不能上QQ，不要修改上述參數，只需建一條網站過濾規則，禁止站點為客戶機的IP位址。


如何限制用戶使用二級代理

啟動帳號管理，編輯該用戶的帳號屬性，將最大連接數設置成5，帶寬設為4096位元組/秒，同時將ccproxy.ini裡的MaxConnectionMode=1改為MaxConnectionMode=0就可以了。此方法可以有效的阻止用戶端開通二級代理，因為只分配了5個連接給此用戶，如果他為其他用戶開通二級代理，會影響其自身的上網狀況。


如何限制用戶端使用網路螞蟻等工具下載

啟動帳號管理，編輯該用戶的帳號屬性，將最大連接數設置成5，帶寬設為4096位元組/秒，同時將ccproxy.ini裡的MaxConnectionMode=1改為MaxConnectionMode=0就可以了。此方法可以有效的阻止用戶端使用下載工具，因為只分配了5個連接給此用戶，如果他使用下載工具，會影響其自身的上網狀況。


如何導入和導入帳號資訊

"帳號"->"導出"，即可把當前的所有的用戶資訊保存起來;
"帳號"->"導入"，即可把原來的用戶資訊導入當前系統。


如何使用流量統計

1) 在CCProxy的"設置"—"高級"—"日誌"—"運行流量統計"前面打勾，並設定"流量統計間隔時間"(默認為10分鐘)，這樣系統會在log文件夾中生成一個文件(如data20030613.txt)，並每隔10分鐘系統在該文件中寫入一次流量統計資料;
2) 點擊"流量統計"，即可打開流量統計文件，觀察到流量記錄(前面的為流進資料,後面的為流出資料);
3) 還可以到主頁上下載CCReport插件，可以根據統計出的流量，計算出每用戶的使用費用。


如何使用帳號的排序功能

在"帳號管理"中，雙擊"IP地址"字樣，所有帳號會按照IP地址大小的依次排列。同理，帳號也可以按照用戶名、MAC地址或連接數的大小次序排列。選擇"確定"後，帳號將按照排序結果保存。


如何簡單有效的防止局域網外部用戶使用代理服務

在"設置"->"高級"->"其他": "禁止局域網外部用戶"前面打勾。這樣可有效防止局域網外部用戶利用您的伺服器發送垃圾郵件，以及未經許可通過您的伺服器代理上網。


撥號服務

CCProxy的撥號服務支援遠端撥號、自動撥號、撥號空閒自動斷開功能。

遠端撥號
1) 在伺服器上手工建立一個撥號連接，並且測試一下這個撥號連接是否有效。
2) "設置"：選擇"遠端撥號"。
3) "設置" -> "高級" -> "撥號"：在 "撥號列表" 中選擇 1)中建立的撥號連接。在 "撥號用戶名", "撥號密碼" 裡填上正確的上網帳號資訊。
4) 用戶端的IE要先設置好HTTP代理。
用戶端訪問 http://ccproxy.connect 就是可以撥號了，如果用戶端用 http://ccproxy.connect.電話號碼.用戶名.密碼 ，則用指定的電話號碼和用戶資訊撥號。
5) 斷開網路連接用 http://ccproxy.disconnect

自動撥號：訪問網站時，如果沒有撥號，代理伺服器可以實現自動撥號。
1) "設置": 選擇"遠端撥號"。
2) "設置" -> "高級" -> "撥號"：選擇"允許自動撥號"。然後在相應的代理協定前打勾，可以實現相應協定的自動撥號功能。

撥號空閒自動斷開：當撥號上網閒置了一段時間，代理伺服器可以自動斷開撥號。
1) "設置": 選擇"遠端撥號"。
2)"設置" -> "高級" -> "撥號"：選擇"撥號空閒斷開時間"，在編輯框裡可以輸入空閒斷開的時間。


網頁緩存

網頁緩存可以將訪問過的網頁保存在緩存裡，在一定時間內，如果客戶訪問同一網頁時，可以直接從緩存裡獲取，這樣可以加快上網速度。 CCProxy的網頁緩存是基於IE的緩存技術，共用了伺服器的IE緩存文件系統。所以要求伺服器安裝IE 4.0或者以上版本。
1) "設置": 選擇"網頁緩存"
2) "設置" -> "高級" -> "緩存"：
"總是從緩存裡讀取"：表示緩存不更新，代理伺服器總是從IE的緩存中獲取網頁數據。這個功能主要用於用戶端下線瀏覽網頁。
"緩存更新時間": 用來設置緩存的更新時間，時間設置越長，緩存裡的資料保存越久。
"IE緩存選項":因為CCProxy的緩存共用了IE的緩存，所以緩存的目錄和緩存的大小需要通過IE來改變。點擊這個按鈕，會自動彈出IE的Internet屬性對話方塊，在"Internet暫存檔案"部分，點擊"設置"按鈕，就可以修改緩存的目錄和大小了。


二級代理

二級代理是指伺服器不能直接上網，必須通過其他代理伺服器上網(如果是通過閘道上網，仍然屬於一級代理)。
1) 在使用二級代理前，先要弄清楚上級代理伺服器的位址，開放協定和埠，以及是否需要身份認證。
2) "設置"->"高級"->"二級代理"：選擇"啟用二級代理"，在代理位址中輸入上級代理伺服器IP或電腦名稱，選擇代理協定HTTP/HTTPS/SOCKS，再輸入對應的埠。若需要驗證密碼，則選擇"需要驗證"，在"用戶名"、"密碼"框中分別輸入指定資訊。

注意事項:
1) 若上級提供了SOCKS5服務，則可以為下級提供包括HTTP/FTP/GOPHER/SOCKS/RTSP/MMS/TELNET等協定在內的幾乎任何服務，本程式可以全部自動轉換；若上級提供了HTTPS服務，則絕大部分服務也可為下級提供，除了QQ/PP等UDP協定；若上級只提供了HTTP服務，則下級只能使用HTTP/FTP/GOPHER協定。
2) 6.0版支援不同的協定可以設置不同的二級代理或者不使用二級代理，即每一個協定都可以使用不同的上級代理和不同的協定或者部分協定使用上級代理，而部分協定可以不使用上級代理，也可以全部使用同一個上級代理和協定。


日誌管理

CCProxy的日誌管理分為在線監視和日誌文件。

在線監視
可以觀察當前用戶的活動。雙擊介面上的綠色網格，可以看到監視當前的用戶連接狀態。

日誌文件
"設置" -> "高級" -> "日誌"：
選擇"保存日誌文件至"，可以將日誌事件保存到日誌文件裡。
"日誌事件選項": 日誌事件除了記錄最基本的時間，用戶名，IP地址和訪問類型外，還可以記錄更詳細的資訊：
"訪問網址" - 記錄用戶通過瀏覽器訪問的站點
"圖片資訊" - 可以記錄用戶訪問的圖像資訊，如果不選擇此項，將在日誌裡遮罩gif,bmp,jpg等圖片訪問資訊。


管理員密碼設置

"設置" -> "高級" -> "其他"，選擇"密碼保護"，輸入相應的密碼就可以了。選擇"啟動時需要密碼"，則啟動CCProxy時也需要輸入登錄密碼。


其他設置

"本地IP地址"的說明:
"設置" -> "本地IP地址"，是指伺服器上與局域網機器連接時所綁定的IP位址。
如果是"單網卡+撥號"或者"單網卡連接局域網+單網卡連接互聯網"，可以自動檢測出本地IP地址。
其他的需要取消"自動檢測"，從網卡列表中選擇一個伺服器綁定的本地IP位址。

"NT服務":
"設置" ->"NT服務"：NT服務只對NT4.0，Win2000，WinXP和Win2003有效。選用NT服務後，可以讓CCProxy在未登錄狀態下工作。

"設置" -> "高級" -> "其他"
"檢測互聯網連接狀態的站點": 主要用來判斷本端伺服器是否與互聯網是否連通，不同站點用分號分隔。
"連接閒置斷開時間": 用來設置用戶端連接代理伺服器的閒置的自動斷開時間。
"禁止局域網外部用戶": 用來阻止互聯網上其他用戶使用本代理伺服器上網。
"自動掃瞄機器名": 用來設置"自動掃瞄"時是否獲取局域網內的機器名。
"開放SOCKS4": 用來設置SOCKS代理服務是否支援SOCKS v4.


常見問題解答及資訊反饋

我們在主頁上定期更新常見問題解答，如果您有什麼問題和建議，歡迎您通過電子郵件反饋到 support@youngzsoft.com，或者發佈在遙志軟體論壇 http://www.youngzsoft.com/php。


聯繫方法

北京新世紀遙志軟體發展有限公司

公司主頁: http://www.youngzsoft.com/cn/
電子郵件: support@youngzsoft.com
用戶論壇: http://bbs.youngzsoft.com/
購買方法: http://www.youngzsoft.com/cn/user.htm
電話號碼: 010-82613296 010-82613926（電話號碼以公佈在主頁上的為準）
傳真號碼: 010-82613926
公司地址: 北京市海澱區西苑操場5號暢春園飯店1-306
郵遞區號: 100080


CCProxy, YoungZSoft 2000-2003